百宝云论坛

 找回密码
 立即注册
查看: 468|回复: 2

百宝云网络验证V4的注册返回值问题

[复制链接]

3

主题

11

帖子

39

积分

一级圣斗士

Rank: 1

积分
39
发表于 2016-10-8 16:50:05 | 显示全部楼层 |阅读模式
易语言调试的
用户名没有被注册过,注册时没有问题,返回空
如果注册的用户名是已经注册过的,返回值是“成功”,好像不太对吧。。。

回复

使用道具 举报

3

主题

11

帖子

39

积分

一级圣斗士

Rank: 1

积分
39
 楼主| 发表于 2016-10-8 16:52:16 | 显示全部楼层
源代码
.版本 2

.子程序 _按钮_注册_被单击
.局部变量 返回信息, 文本型
返回信息 = 红船_注册 (#项目名, 编辑框_注册账号.内容, 编辑框_注册密码.内容, 编辑框_备注信息.内容)
.如果 (返回信息 = “”)
    标题 = “注册成功”
.否则
    标题 = 返回信息

调试信息
* “>>> {"method":"UserReg","param":{"pass":"517788","remark":"","prog":"WGmud"},"user":"mingxueb"}”
* “<<< {"status":0,"result":null}”
* “>>> {"method":"UserReg","param":{"pass":"5177881","remark":"","prog":"WGmud"},"user":"mingxueb"}”
* “<<< {"status":23,"result":"成功"}”
回复 支持 反对

使用道具 举报

0

主题

5

帖子

92

积分

功夫熊猫

Rank: 2

积分
92
发表于 2016-10-9 14:12:28 | 显示全部楼层
好的  已经提交给相关负责的作者处理了
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

技术支持
关闭
售后
在线客服
QQ群:309604797
在线客服

小黑屋|百宝云论坛 ( 湘ICP备15007281号-2 )

GMT+8, 2018-10-23 17:58

Powered by bby! X3.4

© 2015-2018 baibaoyun

快速回复 返回顶部 返回列表